Jamit Software Forum
Welcome, Guest. Please login or register.
September 22, 2019, 08:13:04 pm

Login with username, password and session length
Search:     Advanced search
May 5th, 2010 - Jamit Software Launches the Market!
3,080 Posts in 791 Topics by 1,564,291 Members
Latest Member: patio7pike
* Home Help Search Login Register
+  Jamit Software Forum
|-+  Jamit Job Board Customers
| |-+  User-to-User Support
| | |-+  Can't change POP3 port
« previous next »
Pages: [1] Print
Author Topic: Can't change POP3 port  (Read 16588 times)
shipout
Jammers
Jr. Member
*
Posts: 14


« on: January 30, 2012, 02:24:04 am »

Hi all,

I've just installed Jamit for the first time, and I'm having some trouble with my email configuration.  I've set the POP3 to 995 (instead of the default 110), and set "Use SSL" to YES (OpenSSL is enabled), but Jamit is still attempting to connect on port 110. I get the following error:

Error: 110 could not connect to the host "pop.gmail.com"

My logs confirm that the connection is being attempted on port 110, despite my settings. Yes, I did save the settings first!  Huh

A screenshot of my settings is included. Thanks in advance for any replies!
Logged
cellularnews
Jammers
Jr. Member
*
Posts: 15


« Reply #1 on: February 01, 2012, 04:02:06 pm »

Change the pop address to ssl://pop.gmail.com

Logged
shipout
Jammers
Jr. Member
*
Posts: 14


« Reply #2 on: February 01, 2012, 04:12:13 pm »

Hi,

Thank you very much for your reply. I've been tearing out my hair over the past few days trying to get email to work.

I changed the pop server address to ssl://pop.gmail.com as you suggested, but I'm still getting the same error (I did save the settings).
Here is what my apache error log says:

[Wed Feb 01 16:04:15 2012] [error] [client 70.53.140.121] PHP Warning:  fsockopen(): unable to connect to ssl://pop.gmail.com:110 (Connection timed out) in /var/www/include/lib/mail/pop3.php on line 102, referer: http://shipout.ca/admin/edit_config.php

So the app is still trying to connect to port 110.

My original post has a screenshot of my email settings. Can you see anything else that might be causing the problem?
Logged
cellularnews
Jammers
Jr. Member
*
Posts: 15


« Reply #3 on: February 02, 2012, 03:49:26 pm »

Try hard coding the port into the pop settings... "ssl://pop.gmail.com:995" and see if that helps.

Beyond that - stumped, sorry.
Logged
shipout
Jammers
Jr. Member
*
Posts: 14


« Reply #4 on: February 03, 2012, 08:18:53 pm »

Hi cellularnews,

Yay! I put:

ssl://pop.gmail.com:995

into the "pop3 server address" field on the main config page, and it now works! Cheesy
Thank you so much!

Now to get SMTP to work... I'll report back here if there were any tricks.
Logged
shipout
Jammers
Jr. Member
*
Posts: 14


« Reply #5 on: February 04, 2012, 04:58:41 am »

Well, POP3 worked, but no luck with SMTP. I tried the same trick (ssl://smtp.gmail.com:465). I also tried port 25 (which gmail does allow), which did change the error message I was getting. Anything prefixed with ssl:// or trailing a port number (:465, :25) wouldn't resolve. The furthest I got was with the following settings:

smtp server: smtp.gmail.com
authentication hostname: smtp.gmail.com
smtp port: 25

This gave me an error (in the admin panel's Email Queue List) saying that the "server does not require authentication", which isn't true.

I did make sure that a connection was possible on port 25, by testing with a telnet connection.

I've seen no report anywhere of anyone being able to use gmail (or any authenticated SMTP, actually) with Jamit. Actually, there are a few people in the forums (most of them years ago) who had the same problem, with no reported solution.  :'(
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.156 seconds with 18 queries.