Jamit Software Forum
Welcome, Guest. Please login or register.
August 04, 2021, 08:18:05 pm

Login with username, password and session length
Search:     Advanced search
May 5th, 2010 - Jamit Software Launches the Market!
3,080 Posts in 791 Topics by 1,790,339 Members
Latest Member: SalendPax
* Home Help Search Login Register
+  Jamit Software Forum
|-+  Jamit Job Board Customers
| |-+  User-to-User Support
| | |-+  Mod Rewrite problem - missing vovels
« previous next »
Pages: [1] Print
Author Topic: Mod Rewrite problem - missing vovels  (Read 6037 times)
szabcsee
Jammers
Hero Member
*
Posts: 115


« on: March 07, 2010, 08:28:37 pm »

Hello, I'm running a job board and having a problem with the modrewrite rules maybe someone can help me:

My language is Hungarian so a job title is something like:

lingojob.com -- állás --- mérnöki állás -- termelési részlegvezető

So i would like the url to look like (with mod rewrite) :

http://www.lingojob.com/allas/mernoki/termelesi-reszlegvezeto/660

but currently it looks:

http://www.lingojob.com/allas/m-rn-ki/termel-si-r-szlegvezet/660

Could someone help me with the htaccess code I need for this?

Currently I have:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule ^kategoria/(.+)$ /index.php?cat_name=$1 [NC,L]
RewriteRule ^allas/(.+)$ /index.php?post_permalink=1&post_id=$1 [NC,L]
RewriteRule ^profil/(.+)$ /index.php?show_emp=$1 [NC,L]
RewriteCond %{QUERY_STRING} .+
RewriteRule ^page([0-9]+) /index.php?%{QUERY_STRING}&job_page_link=$1 [NC,L]
RewriteRule ^page([0-9]+) /index.php?job_page_link=$1 [NC,L]
</IfModule>

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule ^pages/(.+) /p.php?p=InfoPages&file=$1 [NC,L]
</IfModule>

Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^lingojob.com [nc]
rewriterule ^(.*)$ http://www.lingojob.com/$1 [r=301,nc]


Logged
CompuDave
Global Moderator
Hero Member
*****
Posts: 173



WWW
« Reply #1 on: March 08, 2010, 06:38:57 am »

You can set this in the mod rewrite section of Admin > Main Config. Set Job Posting Directory to - job/%TITLE%/
Logged
szabcsee
Jammers
Hero Member
*
Posts: 115


« Reply #2 on: March 08, 2010, 08:30:54 am »

Hello,

Thanks for the reply. It is /job/%CATEGORY%/%TITLE%/%ID% the problem is how the modrewrite rule translate the á ő ö ú ü ű characters. They should be a o o u u u but instead it puts - symbols. This is not good.
Logged
szabcsee
Jammers
Hero Member
*
Posts: 115


« Reply #3 on: March 30, 2010, 02:32:10 pm »

It seems that no one knows the answer for this question however it would be great to give some feedback on this as plenty of languages using accents and it is a huge SEO wound having those URLS full of -

Anyone from Jamit can help?
Logged
CompuDave
Global Moderator
Hero Member
*****
Posts: 173



WWW
« Reply #4 on: March 30, 2010, 03:50:38 pm »

I suggest you submit a support ticket so that the Jamit Support Team can address this problem - http://www.jamit.com/support/
Logged
szabcsee
Jammers
Hero Member
*
Posts: 115


« Reply #5 on: April 13, 2010, 09:27:47 am »

Hello CompuDave,

Well I have submitted a ticket as you recommended, 2 weeks ago but still did not get any answers. Bit disappointed with the support.

Best Regards,

szabcsee
Logged
szabcsee
Jammers
Hero Member
*
Posts: 115


« Reply #6 on: April 15, 2010, 02:24:13 pm »

Hello,

Just to let you know that Adam contacted me and the problem is being resolved, so with the next update this won't be a problem anymore.

 Wink Cheesy
Logged
Peter
Administrator
Hero Member
*****
Posts: 248



« Reply #7 on: May 10, 2010, 11:19:59 am »

I'd say it is not an issue with mod rewrite.
Logged

SECURE your site BEFORE you wish you had! Use plugins by COLOSSAL MIND!
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.023 seconds with 17 queries.